summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 574ddd90cbcd..3249a86efa90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,21 @@
# Maintainer: Atif Chowdhury <iftakhar.awal@gmail.com>
pkgname=xcolor-git
-pkgver=0.5.0.100.g0e99e67
-pkgrel=2
+pkgver=0.5.0.101.gf23338a
+pkgrel=1
pkgdesc="Lightweight color picker for X11"
arch=(x86_64)
url="https://github.com/Soft/xcolor"
license=(MIT)
depends=("libxcb")
makedepends=("rust" "cargo" "python")
-source=("$pkgname::git+https://github.com/Soft/xcolor.git" "cargo_fix.patch")
-sha256sums=('SKIP' '58575b5e08ded6af6331f9fd1e22023b7479905f9a7781d99507d33559ee25c9')
+source=("$pkgname::git+https://github.com/Soft/xcolor.git")
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2|cut -d\- -f1).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$pkgname"
- _commit=$(git rev-parse HEAD | cut -c1-7)
- if [ "${_commit}" = "0e99e67" ]; then
- patch -p1 < $startdir/cargo_fix.patch
- fi
-}
-
build() {
cd "$pkgname"
cargo build --release