summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37c9185f8175..338fe9d6977a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,37 @@
-# Maintainer: Manoel Brunnen <manoel.brunnen@gmail.com>
+# Maintainer: Michael Wigham <michael@wigham.net>
+# Contributor: Nils Van Zuijlen <nils.van-zuijlen@mailo.com>, Manoel Brunnen <manoel.brunnen@gmail.com>
pkgname=xctu
-pkgver=6.3.5
+pkgver=6.5.13
pkgrel=0
pkgdesc="Next Generation Configuration Platform for XBee/RF Solutions."
arch=('i686' 'x86_64')
url="http://www.digi.com/products/xbee-rf-solutions/xctu-software/xctu"
license=('custom')
-depends=('java-runtime-common')
+depends=('gtk2' 'java-runtime' 'libxtst' 'alsa-lib' 'gconf' 'nss' 'libglvnd' 'libnet' 'libxt')
options=('!strip')
-# install=$pkgname.install
+
if [[ $CARCH == 'i686' ]]; then
- _setup_file=40002880_G.run
- md5sums=('906fe507935450b3e0f2ff28044c5650')
+ _setup_file=40002880_AJ.run
+ md5sums=('e28c71e26accdcb4d36395e26ba19835')
elif [[ $CARCH == 'x86_64' ]]; then
- _setup_file=40002881_G.run
- md5sums=('f378b0636d5f3b9327e43355c89151ef')
+ _setup_file=40002881_AJ.run
+ md5sums=('229ab2d443eded6184ecaef50ff99913')
fi
source=("http://ftp1.digi.com/support/utilities/$_setup_file"
'launcher.sh'
'xctu.desktop'
'fix.patch')
-md5sums+=('9ebb584444f6e9417bb74c1f4c5792cd'
- '8268deecea042c3d4d557d6a47f1f004'
- '1e0ebe726f6d5304091d6e10d01de7be')
+md5sums+=('672a983dc8d23e4f6a496158d4852b99'
+ '955154d1675975d99f855a213cb0c3ce'
+ '92698e7e64cfcfbc8aae271ff904def6')
noextract=()
prepare() {
chmod u+x $_setup_file
- # ./$_setup_file --prefix $srcdir --mode unattended --unattendedmodeui none
- # prefix option not working:
- printf "\n\n\n\n\ny\n\n$srcdir\n\n\nn\nn\n" | ./$_setup_file --mode text || true
+ ./$_setup_file --installdir $srcdir --mode unattended --unattendedmodeui none
mv $srcdir/XCTU-NG $srcdir/$pkgname
echo $pkgver > $srcdir/$pkgname/version.txt
- # change XCTU's config folder to ~/.config/xctu:
patch -p1 -N < $srcdir/fix.patch
}
@@ -45,8 +43,12 @@ package() {
# Launcher
install -Dm755 $srcdir/launcher.sh $pkgdir/usr/bin/$pkgname
+ # CLI
+ ln -s /opt/xctu/XCTUcmd $pkgdir/usr/bin/XCTUcmd
+
# Desktop file
install -Dm644 $srcdir/$pkgname/icon.xpm $pkgdir/usr/share/icons/hicolor/256x256/apps/xctu.xpm
- install -Dm644 $srcdir/xctu.desktop $pkgdir/usr/share/applications/xctu.desktop
+ install -Dm755 $srcdir/xctu.desktop $pkgdir/usr/share/applications/xctu.desktop
+ install -Dm755 $srcdir/xctu.desktop $pkgdir/opt/$pkgname/XCTU.desktop
}
# vim:set ft=sh: