summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6238ed566848..c7f122e2516d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=xde-applets
-pkgver=0.7
+pkgver=0.8
pkgrel=1
pkgdesc="X Desktop Environment System Tray Icons and Dock Apps"
groups=('xde')
@@ -13,12 +13,15 @@ depends=('libsm' 'libwnck+-git' 'libcanberra' 'libnotify' 'lm_sensors'
makedepends=('dbus-glib' 'libunique' 'xorgproto')
optdepends=('xdg-launch-git: launch with recent update and launch notification')
source=("https://github.com/bbidulock/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.lz")
-md5sums=('a119b60c7c2604e057a72106b147a5a3')
+md5sums=('e862533718cc3f7abba628af200012a9')
build() {
cd $pkgname-$pkgver
- ./configure
- make
+ # gtk2 is using deprecated glib2 declarations
+ ./configure CFLAGS="-Wno-deprecated-declarations $CFLAGS"
+ # Fight unused direct deps
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
+ make CFLAGS="-Wno-deprecated-declarations $CFLAGS"
}
package() {