summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d229e1e7f8a..8e35a203509d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=xde-ctools
-pkgver=1.11
+pkgver=1.12
pkgrel=1
pkgdesc="X Desktop Environment C-language tools"
groups=('xde')
@@ -12,12 +12,15 @@ depends=('libxss' 'libsm' 'libwnck+' 'libcanberra' 'libnotify')
makedepends=('dbus-glib' 'libunique')
optdepends=('xdg-launch: launch with recent update and launch notification')
source=("https://github.com/bbidulock/xde-ctools/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.lz")
-sha256sums=('43130ac08a69083fe74e9efd8b6d40b94463296af1d637c94fb18da697c1f8da')
+sha256sums=('750583c76cf50bdf96f3283914f37fa33b508f4f1692680ec39a0e06685fe02b')
build() {
cd $pkgname-$pkgver
- ./configure --sysconfdir=/etc
- make
+ # gtk2 is using deprecated glib2 declarations
+ ./configure --sysconfdir=/etc CFLAGS="-Wno-deprecated-declarations $CFLAGS"
+ # Fight unused direct deps
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
+ make CFLAGS="-Wno-deprecated-declarations $CFLAGS"
}
package() {