summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8b00801c4f1..16a5a8ff078b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,34 @@
#Contributor: Brian Bidulock <bidulock@openss7.org>
pkgdesc="SR-71 Blackbird theme pack for XDE"
pkgname=xde-theme-blackbirds
-pkgver=1.2.4
+_commit=cdd1bc552200892e36d68fc25f1d3d63dba01e40
+pkgver=1.2.5
pkgrel=1
url="http://www.unexicon.com/"
license=('CCPL:by-nc-nd')
arch=('any')
groups=('xde')
depends=('xde-styles')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/bbidulock/$pkgname/archive/refs/tags/$pkgver.tar.gz")
-md5sums=('928a714279a3b6849932c55c7ff0c0e5')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/bbidulock/xde-theme-blackbirds.git#commit=$_commit")
+md5sums=('SKIP')
+
+# Leaving this for pkgver bumps, not really needed for users hence commenting out.
+#pkgver() {
+# cd $pkgname
+# ./autogen.sh
+# ./configure --version|head -1|awk '{print$3}'
+#
+#}
build() {
- cd $pkgname-$pkgver
+ cd $pkgname
./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname
make DESTDIR="$pkgdir" install
}