summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01213c52738b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Modified from extra/xdg-desktop-portal-kde; original contributors:
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+
+_pkgname=xdg-desktop-portal-lxqt
+pkgname=$_pkgname-git
+pkgver=0.0.0.r1.b3710c0
+pkgrel=1
+pkgdesc='A backend implementation for xdg-desktop-portal using Qt/KF5'
+arch=(x86_64)
+url='https://github.com/lxqt/xdg-desktop-portal-lxqt'
+license=(LGPL)
+depends=(qt5-base kwindowsystem)
+makedepends=(cmake git)
+provides=(xdg-desktop-portal-impl)
+source=(git+$url)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "0.0.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S $_pkgname \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}