summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5adb8cae536d..5e61a4d420e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=xed
pkgver=1.6.3
-pkgrel=2
+pkgrel=3
pkgdesc="A small and lightweight text editor. X-Apps Project."
arch=('i686' 'x86_64' 'armv7h')
license=('GPL')
@@ -12,11 +12,16 @@ makedepends=('gnome-common' 'iso-codes' 'gobject-introspection')
provides=($pkgname)
conflicts=('xed-git' $_pkgname)
url='https://github.com/linuxmint/xed'
-install=xed.install
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/linuxmint/${pkgname}/archive/${pkgver}.tar.gz")
md5sums=('b7aa267ecde3de3753c38e0092811e8b')
+prepare() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ # https://www.archlinux.org/todo/enchant-221-rebuild/
+ sed -i 's/, enchant/, enchant-2/' configure.ac
+}
+
build() {
cd ${srcdir}/${pkgname}-${pkgver}
./autogen.sh --with-gtk=3.0 --prefix="/usr" \