summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2541f538b7bd..9dab5a6322c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# shellcheck shell=bash disable=SC2034,SC2164
_pkgname=xemu
pkgname=$_pkgname-git
-pkgver=0.3.0.r2.gfcd3764cce
+pkgver=0.5.0.r2.g270310e603
pkgrel=1
pkgdesc="Original Xbox emulator (fork of XQEMU)"
arch=('x86_64')
url="https://xemu.app/"
license=('GPL2')
-depends=('sdl2' 'libepoxy' 'pixman' 'gtk3' 'glu')
+depends=('glu' 'gtk3' 'libsamplerate' 'sdl2')
makedepends=('git' 'python')
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -28,8 +28,8 @@ build() {
package() {
cd $_pkgname
# shellcheck disable=SC2154
- install -Dm755 i386-softmmu/qemu-system-i386 "$pkgdir"/usr/bin/$_pkgname
- install -Dm644 -t "$pkgdir"/usr/share/$_pkgname/data data/*
- install -Dm644 ui/xemu.desktop "$pkgdir"/usr/share/applications/$_pkgname.desktop
- install -Dm644 ui/icons/xemu.svg "$pkgdir"/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg
+ install -Dm755 -t "$pkgdir"/usr/bin dist/xemu
+ install -Dm644 -t "$pkgdir"/usr/share/$_pkgname/data dist/data/*
+ install -Dm644 -t "$pkgdir"/usr/share/applications ui/xemu.desktop
+ install -Dm644 -t "$pkgdir"/usr/share/icons/hicolor/scalable/apps ui/icons/xemu.svg
}