summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5492bba8b2b8..259665bdc1f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
-# Credit: Laurent Carlier <lordheavym@gmail.com>
+# based on extra/xf86-video-amdgpu by:
+# Laurent Carlier <lordheavym@gmail.com>
pkgname=xf86-video-amdgpu-git
_pkgname=xf86-video-amdgpu
-pkgver=19.1.0.1
+pkgver=21.0.0.r1.g6936552
pkgrel=1
pkgdesc="X.org amdgpu video driver (git version)"
arch=('x86_64')
@@ -16,18 +17,14 @@ provides=('xf86-video-amdgpu')
groups=('xorg-drivers')
source=("${pkgname}::git+https://gitlab.freedesktop.org/xorg/driver/${_pkgname}.git")
sha256sums=('SKIP')
-pkgver() {
- local version count
-
- cd "${pkgname}"
- version="$(git describe --abbrev=0 --tags)"
- count="$(git rev-list --count ${version}..)"
- printf '%s.%s' "${version#v}" "${count}"|sed 's/^xf86-video-amdgpu-//'
+pkgver() {
+ cd ${pkgname}
+ git describe --long --tags | sed 's/^xf86.video.amdgpu.//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${pkgname}"
+ cd ${pkgname}
# Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
# With them, module fail to load with undefined symbol.
@@ -36,18 +33,20 @@ build() {
export CXXFLAGS=${CXXFLAGS/-fno-plt}
export LDFLAGS=${LDFLAGS/,-z,now}
+ #CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
+
./autogen.sh --prefix=/usr \
--enable-glamor
make
}
check() {
- cd "${pkgname}"
+ cd ${pkgname}
make check
}
package() {
- cd "${pkgname}"
+ cd ${pkgname}
make "DESTDIR=${pkgdir}" install
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"