summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 3 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 626bb29824fd..a22220c5a550 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,25 @@
_pkgname=xf86-video-qxl
pkgname=$_pkgname-git
-pkgver=0.1.5.16.g52c421c
+pkgver=0.1.5.19.g4e1963a
pkgrel=1
pkgdesc='X Window System QXL driver including Xspice server'
arch=('i686' 'x86_64')
url='https://www.spice-space.org'
license=('MIT')
-#depends=('xf86dgaproto' 'xproto' 'fontsproto' 'randrproto' 'renderproto' 'videoproto' 'resourceproto' 'scrnsaverproto' 'spice')
depends=('spice')
optdepends=('python: Xspice server')
makedepends=('git' 'xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=25.2' 'spice-protocol' 'libcacard')
provides=('xf86-video-qxl')
conflicts=('xf86-video-qxl' 'X-ABI-VIDEODRV_VERSION<25' 'X-ABI-VIDEODRV_VERSION>=26')
-source=("git+https://gitlab.freedesktop.org/xorg/driver/$_pkgname.git"
- fix-build-against-current-x-server.diff)
-sha256sums=('SKIP'
- a5e4292d3a6bc9641a8d4ec4d9eb92094ee3d20581c590051e878c8829b9a035)
+source=("git+https://gitlab.freedesktop.org/xorg/driver/$_pkgname.git")
+sha256sums=('SKIP')
pkgver() {
cd $_pkgname
git describe --always | sed 's/xf86-video-qxl.//;s/-/./g'
}
-prepare() {
- cd $_pkgname
- patch -p1 < ../fix-build-against-current-x-server.diff
-}
-
build() {
cd $_pkgname