summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 29 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25b4e0bd0eba..1be026445b01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,39 @@
-# Maintainer : Yamada Hayao <hayao@fascode.net>
-# Contributer: Bernhard Landauer <oberon@manjaro.org>
-
-pkgname="xfce4-calculator-plugin"
-_maj=0.7
-pkgver="${_maj}.1"
+# Maintainer: Dennis Herbrich (Gyroplast) <dennis.herbrich@veloxis.de>
+# Contributor: Yamada Hayao <hayao@fascode.net>
+# Contributor: Bernhard Landauer <oberon@manjaro.org>
+pkgname=xfce4-calculator-plugin
+pkgver=0.7.2
pkgrel=1
-pkgdesc="Calculator plugin for the Xfce4 panel."
+pkgdesc="Simple command line based calculator for the Xfce panel"
arch=('i686' 'x86_64')
-url="http://goodies.xfce.org/projects/panel-plugins/${pkgname}"
-license=('GPL')
-depends=('intltool' 'xfce4-panel')
-install="${pkgname}.install"
-source=("https://archive.xfce.org/src/panel-plugins/xfce4-calculator-plugin/${_maj}/xfce4-calculator-plugin-${pkgver}.tar.bz2")
-sha256sums=('e4016a03c3ef4ebddd97e4135f5e304f80677033c98e19644b9989ec6f5ada81')
+url="https://docs.xfce.org/panel-plugins/xfce4-calculator-plugin"
+license=('GPL-2.0-or-later')
+depends=('xfce4-panel')
+makedepends=('intltool')
+source=("https://archive.xfce.org/src/panel-plugins/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('d1f622bea41a90c1686bf9f13c488ab28e995e2762b84712dea9027e0c94028b')
build() {
- cd "${pkgname}-${pkgver}"
- [[ -f "./Makefile" ]] && make distclean
- "./configure" --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --disable-static
- make
+ cd "${pkgname}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
}
package() {
cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}/" install
}
+# vim:set ts=2 sw=2 et: