summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0cb7cfb434f5..fa1cf7f1ceed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Contributor: Sebastian Wolf <fatmike303@gmail.com>
+# Maintainer: Sebastian Wolf <fatmike303@gmail.com>
#
# This fixes the following issue:
# https://bugzilla.xfce.org/show_bug.cgi?id=9693
pkgname=xfce4-panel-borderfix
_pkgname=xfce4-panel
-pkgver=4.12.2
+pkgver=4.14.0
pkgrel=1
pkgdesc="Panel for the Xfce desktop environment with a patch fixing border behavior using two monitors stacked on top each other"
arch=('x86_64')
@@ -14,14 +14,14 @@ license=('GPL2')
groups=('xfce4')
provides=($_pkgname)
conflicts=($_pkgname)
-depends=('exo' 'garcon' 'libxfce4ui' 'libwnck' 'hicolor-icon-theme' 'desktop-file-utils')
-makedepends=('intltool' 'gtk-doc')
+depends=('exo' 'garcon' 'libxfce4ui' 'xfconf' 'libwnck3' 'hicolor-icon-theme' 'desktop-file-utils')
+makedepends=('intltool' 'gobject-introspection' 'vala')
source=(
https://archive.xfce.org/src/xfce/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2
'borderfix.patch'
)
sha256sums=(
- '42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9'
+ 'd5f8f3bd7e142139987e5e62cda26135a424baabb5e47aa0c23b4169d0a66ef4'
'effbe9c073f37987f877a168beddcfc03a38ec3adcba57a2cce3ce93b3420176'
)
@@ -31,7 +31,6 @@ prepare() {
build() {
cd "$srcdir/$_pkgname-$pkgver"
-
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -39,8 +38,6 @@ build() {
--localstatedir=/var \
--disable-static \
--enable-gio-unix \
- --enable-gtk-doc \
- --enable-gtk3 \
--disable-debug
make
}
@@ -49,5 +46,3 @@ package() {
cd "$srcdir/$_pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
-
-# vim:set ts=2 sw=2 et: