summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3017a26e8c27..be6c0a4822c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: twa022 <twa022 at gmail dot com>
+# 0: no, 1: yes
+_enable_polkit=1
+
_pkgname=xfce4-session
pkgname=${_pkgname}-devel
pkgver=4.13.0
-pkgrel=1
+pkgrel=2
pkgdesc="A session manager for Xfce"
arch=('i686' 'x86_64')
url="http://www.xfce.org/"
license=('GPL2')
groups=('xfce4')
-depends=('libxfce4ui' 'libwnck3' 'libsm' 'xorg-iceauth' 'upower' 'xorg-xinit'
- 'xorg-xrdb' 'hicolor-icon-theme')
-makedepends=('intltool' 'xfce4-dev-tools' 'polkit')
-optdepends=('polkit: polkit support'
- 'gnome-keyring: for keyring support when GNOME compatibility is enabled'
+depends=('libxfce4ui' 'libwnck3' 'xorg-iceauth' 'xorg-xinit' 'hicolor-icon-theme')
+makedepends=('intltool' 'xfce4-dev-tools')
+optdepends=('gnome-keyring: for keyring support when GNOME compatibility is enabled'
'xscreensaver: for locking screen with xflock4'
'gnome-screensaver: for locking screen with xflock4'
'xlockmore: for locking screen with xflock4')
@@ -23,6 +24,8 @@ replaces=('xfce-utils')
source=(http://archive.xfce.org/src/xfce/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2)
sha256sums=('3e02b124c6a282d9b1af0b30696d5256b1c2e56618992b49062314ed3ea5d3a1')
+[[ ${_enable_polkit} -eq 1 ]] && depends+=( 'polkit' )
+
build() {
cd "$srcdir/$_pkgname-$pkgver"