summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cefdbc7087a3..37f20e80e283 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,16 @@
-# Maintainer: Ehsan Ghorbannezad <ehsangn@protonmail.ch>
-_pkgname='xkblayout-subscribe'
-pkgname="${_pkgname}-git"
+# Maintainer: Ehsan Ghorbannezad <ehsan at disroot dot org>
+_pkgname=xkblayout-subscribe
+pkgname=$_pkgname-git
pkgver=r1.bc13b72
-pkgrel=1
+pkgrel=2
pkgdesc='Subscribe to X keyboard layout events. useful for updating statusbars.'
-arch=('x86_64')
-url='https://github.com/soystemd/xkblayout-subscribe'
-license=('GPL')
-depends=('libpulse')
-makedepends=('git' 'pkgconf')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("git+${url}.git")
-md5sums=('SKIP')
+url=https://github.com/soystemd/xkblayout-subscribe
+arch=(x86_64)
+license=(GPL)
+depends=(libpulse)
+makedepends=(git pkgconf)
+source=("git+$url.git")
+md5sums=(SKIP)
pkgver() {
cd "$_pkgname"
@@ -25,7 +23,7 @@ build() {
}
package() {
- cd "${_pkgname}"
+ cd "$_pkgname"
make PREFIX=/usr DESTDIR="$pkgdir" install
- install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/${pkgname}/README.md"
}