summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8776a9543ae9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: jjacky
+# Contributor: MichaƂ Siejak <my_fistname@my_lastname.pl>
+pkgname=xlsh-without-x
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="eXtended Login Shell - fast, minimalistic login replacement (without X support)"
+arch=('i686' 'x86_64')
+url="https://github.com/Nadrin/xlsh/wiki"
+license=('GPL3')
+depends=('pam' 'readline')
+provides=('xlsh=0.2.2')
+source=(https://github.com/Nadrin/xlsh/tarball/master
+ patch)
+install=xlsh.install
+
+build() {
+ cd "$srcdir"
+
+ folder=$(ls |grep Nadrin)
+ mv $folder/* .
+ rmdir $folder
+
+ patch -p1 -i patch
+
+ make
+}
+
+package() {
+ cd "$srcdir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums=('cf78ceec269cc3e35797fe6e8631c3b3'
+ 'bf4e6b42787da0988ae56456d1246937')