summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5aee756b5dc..fd5c6af1fe21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,6 +32,10 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr --libexecdir=/lib --enable-shared
+ # Rid flags not used by Ada.
+ CFLAGS="${CFLAGS//-Wformat}"
+ CFLAGS="${CFLAGS//-Werror=format-security}"
+
# Make using a single job (-j1) to avoid the same file being compiled at the same time.
make -j1 GPRBUILD_OPTIONS=-R
}