summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 035092af623b..0df97ff47ac9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Martin Poljak <martin 'at' poljak 'dot' cz>
pkgname=xnviewmp
-pkgver=0.83
+pkgver=0.84
pkgrel=1
pkgdesc="An efficient multimedia viewer, browser and converter."
url="http://www.xnview.com/en/xnviewmp/"
@@ -18,10 +18,10 @@ license=('custom')
depends=('glib2' 'expat' 'libpng12' 'gstreamer0.10-base' 'desktop-file-utils' 'libxslt' 'qt5-multimedia' 'qt5-webkit' 'qt5-svg' 'qt5-x11extras')
optdepends=('gvfs: support for moving files to trash')
-source_i686=("http://download.xnview.com/XnViewMP-linux.tgz")
source_x86_64=("http://download.xnview.com/XnViewMP-linux-x64.tgz")
-md5sums_x86_64=('3c2c5032a0be2b1f0976b50adad8c80b')
-md5sums_i686=('4673c827de8aa326761433b2eda85a6b')
+md5sums_x86_64=('bbb8bfac5a212103830c9b1dca51c2ae')
+source_i686=("http://download.xnview.com/XnViewMP-linux.tgz")
+md5sums_i686=('75e9e03aa41da988eb66524574794b31')
package() {
install -d -m755 "${pkgdir}/opt/${pkgname}"
@@ -33,6 +33,15 @@ package() {
install -m644 "${startdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -D -m644 "${srcdir}/XnView/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Remove the bundled framework libs (Qt and icu). They don't even work in 0.84,
+ # and at least for now it works with the system libraries. Also everyone likes
+ # dividing their package size by 4 :-)
+ rm "${pkgdir}/opt/${pkgname}/lib/"lib*
+
+ # Clean up
+ rm "${pkgdir}/opt/${pkgname}/XnView.desktop"{,~}
+ chmod -x "${pkgdir}/opt/${pkgname}/xnview.png"
}
# vim:set ts=2 sw=2 et: