summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 23 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e89504a3babf..c2ce2895ca46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgbase=xorg-server
pkgname=('xorg-server-dev' 'xorg-server-xephyr-dev' 'xorg-server-xdmx-dev' 'xorg-server-xvfb-dev' 'xorg-server-xnest-dev' 'xorg-server-xwayland-dev' 'xorg-server-common-dev' 'xorg-server-devel-dev')
pkgver=1.19.3 # https://lists.x.org/archives/xorg/2017-March/058662.html
-pkgrel=2 # https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/xorg-server&id=013fa1ab41b5a4f8ba9bd1072810daacc17644a4
+pkgrel=3 # https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/xorg-server&id=c24304917e61de5de15695065f8a9be89d77818c
arch=('i686' 'x86_64')
license=('custom')
groups=('xorg')
@@ -20,6 +20,9 @@ source=(${url}/releases/individual/xserver/${_pkgbase}-${pkgver}.tar.bz2{,.sig}
nvidia-add-modulepath-support.patch
xserver-autobind-hotplug.patch
modesetting-Set-correct-DRM-event-context-version.patch
+ CVE-2017-10971.patch
+ CVE-2017-10972.patch
+ bug99708.patch
xvfb-run
xvfb-run.1)
validpgpkeys=('7B27A3F1A6E18CD9588B4AE8310180050905E40C'
@@ -30,6 +33,9 @@ sha256sums=('677a8166e03474719238dfe396ce673c4234735464d6dadf2959b600d20e5a98'
'914a8d775b708f836ae3f0eeca553da3872727a2e4262190f4d5c01241cb14e8'
'fcaf536e4fc307958923b58f2baf3d3102ad694efc28506f6f95a9e64483fa57'
'831a70809e6bec766138d7a1c96643732df9a2c0c5f77ee44b47ce4be882e0af'
+ '3950d5d64822b4a34ca0358389216eed25e159751006d674e7cb491aa3b54d0b'
+ '700af48c541f613b376eb7a7e567d13c0eba7a835d0aaa9d4b0431ebdd9f397c'
+ '67013743ba8ff1663b233f50fae88989d36504de83fca5f93af5623f2bef6920'
'ff0156309470fc1d378fd2e104338020a884295e285972cc88e250e031cc35b9'
'2460adccd3362fefd4cdc5f1c70f332d7b578091fb9167bf88b5f91265bbd776')
@@ -45,11 +51,27 @@ prepare() {
msg2 "merged in trunk"
patch -Np1 -i ../modesetting-Set-correct-DRM-event-context-version.patch
+ msg2 "Security: CVE-2017-10971"
+ patch -Np1 -i ../CVE-2017-10971.patch
+
+ msg2 "Security: CVE-2017-10972"
+ patch -Np1 -i ../CVE-2017-10972.patch
+
+ msg2 "Fix Glamor lines: https://bugs.archlinux.org/task/53404"
+ patch -Np1 -i ../bug99708.patch
+
msg2 "Starting autoreconf..."
autoreconf -vfi
}
build() {
+ # Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
+ # With them, modules fail to load with undefined symbol.
+ # See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
+ export CFLAGS=${CFLAGS/-fno-plt}
+ export CXXFLAGS=${CXXFLAGS/-fno-plt}
+ export LDFLAGS=${LDFLAGS/,-z,now}
+
cd "${_pkgbase}-${pkgver}"
msg2 "Starting ./configure..."