summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43364631e10e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: q234 rty <q23456yuiop at gmail dot com>
+# Contributor: lilydjwg <lilydjwg@gmail.com>
+# Contributor: AndyRTR <andyrtr@archlinux.org>
+
+pkgname=xorg-xwayland-hidpi-xprop
+pkgver=22.1.3
+pkgrel=1
+arch=('x86_64')
+license=('custom')
+url="https://xorg.freedesktop.org"
+pkgdesc="run X clients under wayland, with !733 HiDPI patch"
+depends=('nettle' 'libepoxy' 'systemd-libs' 'libxfont2'
+ 'pixman' 'xorg-server-common' 'libxcvt')
+makedepends=('meson' 'xorgproto' 'xtrans' 'libxkbfile' 'dbus'
+ 'xorg-font-util'
+ 'wayland' 'wayland-protocols'
+ 'libdrm' 'mesa-libgl'
+ 'systemd'
+ 'egl-wayland'
+)
+source=(https://xorg.freedesktop.org/archive/individual/xserver/xwayland-$pkgver.tar.xz{,.sig} hidpi.patch)
+sha512sums=('be15cb398f9a8aad70352d09b0745c827d4766d5996e817b92c828b5ede27b10186c7ee319901abdc5e141da97170a3ace039269146461d4e2ceb5002a7c35b4'
+ 'SKIP' d0e7dfe38157947dc4b3a3e7ac0c867d06eeb8d760035227a7cb4aca987a91053cc3c7c4f50d4ade6f1eb7fad631a173ceb75c6b9a896dc22a3aba2221264131)
+provides=('xorg-server-xwayland' 'xorg-xwayland')
+conflicts=('xorg-server-xwayland' 'xorg-xwayland')
+replaces=('xorg-server-xwayland')
+#validpgpkeys=('B09FAF35BE914521980951145A81AF8E6ADBB200') # "Michel Daenzer <michel@daenzer.net>"
+validpgpkeys=('67DC86F2623FC5FD4BB5225D14706DBE1E4B4540') # "Olivier Fourdan <fourdan@xfce.org>"
+options=('debug' 'strip')
+
+prepare() {
+ cd "${srcdir}/xwayland-$pkgver"
+ patch -Np1 < ../hidpi.patch
+}
+
+build() {
+ arch-meson xwayland-$pkgver build \
+ -D ipv6=true \
+ -D xvfb=false \
+ -D xdmcp=false \
+ -D xcsecurity=true \
+ -D dri3=true \
+ -D xwayland_eglstream=true \
+ -D glamor=true \
+ -D xkb_dir=/usr/share/X11/xkb \
+ -D xkb_output_dir=/var/lib/xkb
+
+ # Print config
+ meson configure build
+ ninja -C build
+}
+
+package() {
+
+ # bin + manpage + .pc file
+ install -m755 -Dt "${pkgdir}"/usr/bin build/hw/xwayland/Xwayland
+ install -m644 -Dt "${pkgdir}"/usr/share/man/man1 build/hw/xwayland/Xwayland.1
+ install -m644 -Dt "${pkgdir}"/usr/lib/pkgconfig build/hw/xwayland/xwayland.pc
+
+ # license
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xwayland-$pkgver/COPYING
+}