summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30b670d4f96d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Yangtse Su <i@yangtse.me>
+
+_pkgname=xpadneo
+pkgname=xpadneo-dkms-git
+pkgver=0.r209.g38f3f71
+pkgrel=1
+pkgdesc='Advanced Linux Driver for Xbox One S Wireless Gamepad'
+arch=('x86_64')
+url='https://github.com/atar-axis/xpadneo'
+license=('GPL')
+depends=('dkms' 'linux-headers')
+makedepends=('git')
+source=('git+https://github.com/atar-axis/xpadneo.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git log -1 --format='%h')"
+ else
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git log -1 --format='%h')"
+ fi
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ source VERSION
+
+ echo "* copying module into /usr/src"
+ install -dm755 ${pkgdir}/usr/src/hid-xpadneo-${VERSION}
+ cp --recursive $PWD/hid-xpadneo/* ${pkgdir}/usr/src/hid-xpadneo-${VERSION}
+}