summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e40dfc4c1326
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org
+# Contributor: Gilles CHAUVIN <gcnweb@gmail.com>
+
+pkgname=xplanet-svn
+_pkgname=xplanet
+pkgver=20130526.202
+pkgrel=1
+pkgdesc='Renders an image of the earth into the X root window'
+url='http://xplanet.sourceforge.net/'
+arch=('i686' 'x86_64' 'armv7h')
+license=('GPL2')
+makedepends=('subversion')
+depends=('pango' 'libtiff' 'libxss')
+source=("${_pkgname}::svn://svn.code.sf.net/p/xplanet/code/trunk")
+sha1sums=('SKIP')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ svn info | awk '/Revision/{r=$2}/Date/{gsub(/-/,"");d=$4}END{print d"."r}'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./configure --prefix=/usr --with-freetype
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make prefix="${pkgdir}"/usr install
+}