summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8e74f82b074..f99334ffc977 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,34 @@
# Maintainer: Nate Simon <njsimon10@gmail.com>
pkgname=xplayer
-pkgver=2.2.8
-pkgrel=1
+pkgver=2.4.2
+pkgrel=3
pkgdesc="Simple media player. X-Apps Project."
arch=('i686' 'x86_64' 'armv7h')
license=('GPL')
-depends=('clutter-gtk' 'clutter-gst' 'xplayer-plparser'
+depends=(
+ 'clutter-gtk' 'clutter-gst' 'xplayer-plparser'
'desktop-file-utils' 'iso-codes' 'yelp-xsl'
'libpeas' 'gsettings-desktop-schemas' 'dbus-glib'
- 'python2-gobject' 'gst-plugins-base' 'gst-plugins-good'
- 'xapps')
-makedepends=('gnome-common' 'gtk-doc' 'gobject-introspection' 'vala' 'python-xdg')
+ 'python-gobject' 'gst-plugins-base' 'gst-plugins-good'
+ 'xapps'
+)
+makedepends=(
+ 'gnome-common' 'gtk-doc' 'gobject-introspection' 'vala'
+ 'python-pylint' 'lirc' 'zeitgeist' 'grilo')
optdepends=(
'gst-libav: Extra media codec support'
- 'python2-xdg: Subtitle downloader plugin'
+ 'lirc: Infrared remote control plugin'
+ 'zeitgeist: Zeitgeist interface plugin'
+ 'grilo: Grilo plugins'
+ 'yelp: View help and documentation from the app'
)
provides=($pkgname)
conflicts=('xplayer-git')
url='https://github.com/linuxmint/xplayer'
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/linuxmint/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('ea45bc00713ef881b3e8dbbe49fd9923')
+md5sums=('00bfa48048b789cc0e79b3b0e38df117')
build() {
@@ -38,4 +45,3 @@ package(){
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR="$pkgdir/" install
}
-