summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 14 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3f2da413b6ab..80dbd80c85c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,17 @@
-# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Maintainer: Cobalt Space <cobaltspace at protonmail dot com>
+# Contributor: Chocobo1 <chocobo1 AT archlinux DOT net>
-pkgname=xrdesktop
+_pkgname=xrdesktop
+pkgname=${_pkgname}0.15
pkgver=0.15.2
-pkgrel=3
+pkgrel=1
pkgdesc="Library for XR interaction with classical desktop compositors"
arch=('i686' 'x86_64')
url="https://gitlab.freedesktop.org/xrdesktop/xrdesktop"
license=('MIT')
-depends=('glibc' 'glib2' 'gulkan' 'gxr')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+depends=('glibc' 'glib2' 'gxr>=0.15' 'gxr<0.16')
makedepends=('meson' 'glslang' 'gtk-doc' 'python-gobject' 'vulkan-headers')
optdepends=('python')
source=("https://gitlab.freedesktop.org/xrdesktop/xrdesktop/-/archive/$pkgver/xrdesktop-$pkgver.tar.bz2")
@@ -15,25 +19,16 @@ sha256sums=('4745f55298188a16e6411394bb55a691a251915c2857a6f594f9336721cc9e67')
build() {
- cd "$pkgname-$pkgver"
-
- meson \
- --buildtype=plain \
- --prefix="/usr" \
- --sbindir="bin" \
- "_build"
- meson compile -C "_build"
+ arch-meson "$_pkgname-$pkgver" "build" -Dtests=false
+ meson compile -C "build"
}
check() {
- cd "$pkgname-$pkgver"
-
- #meson test -C "_build"
+ true
+ #meson test -C "build"
}
package() {
- cd "$pkgname-$pkgver"
-
- meson install -C "_build" --destdir "$pkgdir"
- install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/xrdesktop"
+ meson install -C "build" --destdir "$pkgdir"
+ install -Dm644 "$_pkgname-$pkgver/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
}