summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac2215693e06..9884314c00a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,21 +6,18 @@
# Contributor: Mathias R. <pu154r@overlinux.org>
pkgname=xrdp
pkgver=0.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="An open source remote desktop protocol (RDP) server"
url="http://xrdp.sourceforge.net/"
arch=('i686' 'x86_64' 'armv6h')
license=('Apache')
-makedepends=('libpulse' 'fuse')
-depends=('tigervnc' 'libxrandr')
-optdepends=('libpulse: to use the pule audio module'
- 'fuse: to use the file clipboard module')
+depends=('tigervnc' 'libjpeg-turbo' 'libxrandr' 'libpulse' 'fuse')
backup=('etc/xrdp/sesman.ini' 'etc/xrdp/xrdp.ini')
install=xrdp.install
source=(https://github.com/neutrinolabs/${pkgname}/archive/v${pkgver}.tar.gz
- arch-config.diff)
+ fixups.patch)
md5sums=('2b0c3affc65ee77ad251514c62896757'
- '12bcbdf83cae9754da5e39aaf5e013e8')
+ '07f35f8700cd9384f5d13117fd3a4e04')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -31,7 +28,8 @@ prepare() {
sed -i 's|/usr/local/sbin|/usr/bin|' instfiles/xrdp.sh
sed -i 's|/usr/sbin|/usr/bin|' instfiles/xrdp.service
sed -i 's|/usr/sbin|/usr/bin|' instfiles/xrdp-sesman.service
-# patch -p1 < ../arch-config.diff
+
+ patch -p2 -b -z .orig <../fixups.patch
./bootstrap
}
@@ -47,12 +45,12 @@ build() {
--enable-simplesound \
--enable-fuse \
--enable-loadpulsemodules
- make
+ make V=0
}
package() {
- cd "${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir" install
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}