summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ef59d5fc839e..c6d4f8c7e340 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,32 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
# Contributor: Tau Tsao <realturner at gmail.com>
pkgname=xrdp-devel-git
-pkgver=0.9.1.r32.g7b32fc86
+_pkgname=xrdp
+pkgver=0.9.16.r731.g67c297d2
pkgrel=1
pkgdesc="An open source remote desktop protocol (RDP) server - GIT version"
-url="https://github.com/neutrinolabs/xrdp"
+url="https://github.com/neutrinolabs/$_pkgname"
arch=('i686' 'x86_64' 'armv6h')
license=('Apache')
makedepends=('git' 'nasm')
depends=('tigervnc' 'libxrandr' 'lame' 'opus' 'fuse')
-conflicts=('xrdp')
-provides=('xrdp=0.9.1')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}=${pkgver%%.r*}-${pkgrel}")
backup=('etc/xrdp/sesman.ini' 'etc/xrdp/xrdp.ini')
install="${pkgname}.install"
source=("$pkgname::git+https://github.com/neutrinolabs/xrdp.git#branch=devel"
"arch-config.diff")
md5sums=('SKIP'
- 'b41c3d596a582d00e83cd55c756e9ee4')
+ '997ade88ee064c3aed10d226dd4af354')
pkgver() {
cd $pkgname
- printf "0.9.1.r%s.g%s" "$(git rev-list --count v0.9.1..HEAD)" "$(git rev-parse --short HEAD)"
+ printf "0.9.16.r%s.g%s" "$(git rev-list --count v0.9.16..HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd $pkgname
- patch -Np2 -b -z .orig < ../arch-config.diff
+ patch -Np2 -b -z .orig <../arch-config.diff
./bootstrap
}
@@ -35,6 +36,7 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--sbindir=/usr/bin \
+ --libexecdir=/usr/lib \
--with-systemdsystemdunitdir=/usr/lib/systemd/system \
--enable-jpeg \
--enable-tjpeg \
@@ -43,6 +45,8 @@ build() {
--enable-rfxcodec \
--enable-mp3lame \
--enable-pixman
+ # Fight unused direct deps
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
make V=0
}