summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e487ecd8aca0..88586a8ee8db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,21 @@
# Maintainer: chn <g897331845@gmail.com>
pkgname=xtensor-io
pkgver=0.12.6
-pkgrel=1
+pkgrel=2
pkgdesc="xtensor plugin to read and write images, audio files, numpy (compressed) npz and HDF5"
arch=('any')
url="https://github.com/xtensor-stack/xtensor-io"
license=('BSD-3-Clause')
-depends=('xtensor' 'openimageio' 'libsndfile' 'zlib' 'blosc' 'gdal')
+depends=('xtensor' 'openimageio' 'libsndfile' 'zlib' 'highfive' 'hdf5' 'blosc' 'gdal')
makedepends=('cmake')
source=(
- "${pkgname}-${pkgver}.tar.gz::https://github.com/xtensor-stack/xtensor-io/archive/${pkgver}.tar.gz")
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/xtensor-stack/xtensor-io/archive/${pkgver}.tar.gz"
+ '001-install-libdeps.patch')
+
+prepare() {
+ cd "$srcdir"
+ patch -Np0 < 001-install-libdeps.patch
+}
build() {
cd "${pkgname}-${pkgver}"
@@ -20,6 +26,7 @@ build() {
-DHAVE_OIIO=ON \
-DHAVE_SndFile=ON \
-DHAVE_ZLIB=ON \
+ -DHAVE_HighFive=ON \
-DHAVE_Blosc=ON \
-DHAVE_GDAL=ON \
..
@@ -31,4 +38,5 @@ package() {
make install
}
-sha512sums=('b73f180097540da998ff9b6974050e335d7c4e33c3c46c0f3abdedffc44eb59ba6cdba1508885a71e7749f3bc3a9ff1499e105332dff5e2b5e23e2e96e542924')
+md5sums=('8ac452c45cb33104b381b01d7283d2ee'
+ '0eb14beeb17d2f6d9813e29e78643c48')