summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 14 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4129a8b41189..7938548317ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,75 +1,38 @@
##
# Maintainer: pyamsoft <pyam(dot)soft(at)gmail(dot)com>
+#
+# Updated by jonathon: https://aur.archlinux.org/account/jonathon
##
_gitname=xwinwrap
-# shellcheck disable=SC2034
-pkgname=xwinwrap-git
-# shellcheck disable=SC2034
+pkgname="${_gitname}"-git
pkgdesc="Fork of XwinWrap from ujjwal96 on GitHub"
-# shellcheck disable=SC2034
pkgver=r5.ec32e9b
-# shellcheck disable=SC2034
pkgrel=1
-# shellcheck disable=SC2034
-arch=('any')
-# shellcheck disable=SC2034
+arch=('x86_64')
makedepends=('git')
-# shellcheck disable=SC2034
-depends=()
-# shellcheck disable=SC2034
-optdepends=()
-# shellcheck disable=SC2034
+depends=('libx11' 'libxext' 'libxrender')
provides=('xwinwrap')
-# shellcheck disable=SC2034
conflicts=('xwinwrap')
-# shellcheck disable=SC2034
-license=('Other/Open Source')
-# shellcheck disable=SC2034
+license=(custom)
url="https://github.com/ujjwal96/xwinwrap"
-
-##
-# The SHA256 is constantly changing since this is
-# pulled from git so skip the verification check
-##
-# shellcheck disable=SC2034
-sha256sums=('SKIP')
-# shellcheck disable=SC2034
-source=("${_gitname}::git+${url}#branch=master")
-
-###############################################################################
+source=("git+${url}#branch=master" LICENSE)
+sha256sums=('SKIP' '9b445615c864519effd483f60c9877de671708f6c3807841ef1514490ae61903')
pkgver() {
- # shellcheck disable=SC2154
- cd "$srcdir/$_gitname" || {
- msg "Error couldn't cd into $srcdir/$_gitname"
- return 1
- }
-
- # From
- # https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function
- # If there are no tags then use number of revisions since beginning of the history:
+ cd "${_gitname}" || return 1
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- # shellcheck disable=SC2154
- cd "$srcdir/$_gitname" || {
- msg "Error couldn't cd into $srcdir/$_gitname"
- return 1
- }
-
- make
+ make -C "${_gitname}" || return 1
}
package() {
- cd "$srcdir/$_gitname" || {
- msg "Error couldn't cd into $srcdir/$_gitname"
- return 1
- }
+ # From https://bazaar.launchpad.net/~shantanu-goel/xwinwrap/devel/view/head:/xwinwrap.c
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
- chmod 755 xwinwrap
- mkdir -p "${pkgdir}/usr/bin"
- cp xwinwrap "${pkgdir}/usr/bin/xwinwrap"
+ cd "${_gitname}" || return 1
+ install -D xwinwrap "${pkgdir}"/usr/bin/xwinwrap
}