summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90e75ca8bdcc..7541bf29869a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,7 +53,10 @@ build() {
# The unity build takes can take up to 2 GB of RAM per target, so if the
# system does not have enough RAM to build everything at once we'll limit the
# number of concurrent jobs
- total_memory=$(free --gibi --si | awk '/^Mem:/ { print $2 }')
+ #
+ # NOTE: The `LANG=C` is needed because apparently the `pt_BR.UTF-8` locale
+ # changes `Mem:` to `Mem.:`, so who knows what other locales might do
+ total_memory=$(env LANG=C free --gibi --si | awk '/^Mem:/ { print $2 }')
if [ "$total_memory" -le 4 ]; then
echo -e "\n$total_memory gigabytes of RAM detected, limiting the number of build jobs to 1\n"
ninja -C build -j1