summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 252da65a4105..5b54b14947c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=yabridge-git
_pkgname=yabridge
pkgver=3.6.0.r24.ga94be563
-pkgrel=1
+pkgrel=2
pkgdesc="A modern and transparent way to use Windows VST2 and VST3 plugins on Linux"
arch=('x86_64')
url="https://github.com/robbert-vdh/yabridge"
@@ -52,15 +52,9 @@ build() {
# NOTE: The `LANG=C` is needed because apparently the `pt_BR.UTF-8` locale
# changes `Mem:` to `Mem.:`, so who knows what other locales might do
total_memory=$(env LANG=C free --gibi --si | awk '/^Mem:/ { print $2 }')
- if [ "$total_memory" -le 4 ]; then
- echo -e "\n$total_memory gigabytes of RAM detected, limiting the number of build jobs to 1\n"
- ninja -C build -j1
- elif [ "$total_memory" -le 8 ]; then
- echo -e "\n$total_memory gigabytes of RAM detected, limiting the number of build jobs to 3\n"
- ninja -C build -j3
- else
- ninja -C build
- fi
+ num_jobs=$((total_memory / 4))
+ echo -e "\n$total_memory gigabytes of RAM detected, limiting the number of build jobs to $num_jobs\n"
+ ninja -C build -j"$num_jobs"
}
package() {