summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2644b778f9be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=yaloco
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='Yet Another Log Colorizer'
+arch=(x86_64)
+url='https://github.com/xyproto/yaloco'
+license=(MIT)
+makedepends=(git go)
+source=("git+$url#tag=v$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname
+
+ go build .
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: