summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 12 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d086a160ee24..a0bc542a86da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,48 +2,40 @@
# Contributors: Frederic Bezies, Ronan Rabouin
pkgname=yamagi-quake2-xatrix
-pkgver=2.05
-pkgrel=2
+pkgver=2.12
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Quake II - Mission Pack 1 ('The Reckoning') for yamagi-quake2"
-url="http://www.yamagi.org/quake2/"
+url="https://www.yamagi.org/quake2/"
license=('GPL' 'custom')
depends=('sh' 'yamagi-quake2')
-makedepends=('cmake')
install=$pkgname.install
-source=("http://deponie.yamagi.org/quake2/${pkgname#*-}-$pkgver.tar.xz"
+source=("https://deponie.yamagi.org/quake2/${pkgname#*-}-$pkgver.tar.xz"
"$pkgname.sh"
"$pkgname.desktop")
-sha256sums=('5615c87db9d3a45c076db5dd04861090c146ba1b4f40238d79b8755df993a401'
+sha256sums=('92d0c109fe65cd1b92e711afe3bd26aa77bc0b91f1c03fb753e36e1bf012d3c5'
'7c60d4bd78a528f5cf08425cfdcb87dacf574d3912c44439e623e35f37fbc972'
'e65add2561c7dc4a14061e17a24436f768b69968fbc6fa06022acf9e17d80854')
-prepare() {
- rm -rf build
- mkdir -p build
-}
-
build() {
- cd build
- cmake ../${pkgname#*-}-$pkgver -DCMAKE_BUILD_TYPE=Release
- make
+ make -C ${pkgname#*-}-$pkgver
}
package() {
- # game library
- install -Dm644 build/Release/game.so "$pkgdir"/usr/lib/yamagi-quake2/xatrix/game.so
-
cd ${pkgname#*-}-$pkgver
+ # game library
+ install -Dm644 -t "$pkgdir"/usr/lib/yamagi-quake2/xatrix release/game.so
+
# game launcher
install -Dm755 ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
# doc
- install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
+ install -Dm644 -t "$pkgdir"/usr/share/doc/$pkgname README
# desktop entry
- install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm644 -t "$pkgdir"/usr/share/applications ../$pkgname.desktop
# license
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
}