summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b31d67506ff..19a2ee988fc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,43 @@
# Contributors: Frederic Bezies, Ronan Rabouin
pkgname=yamagi-quake2-xatrix
-pkgver=2.04
+pkgver=2.05
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Quake II - Mission Pack 1 ('The Reckoning') for yamagi-quake2"
url="http://www.yamagi.org/quake2/"
license=('GPL' 'custom')
depends=('sh' 'yamagi-quake2')
+makedepends=('cmake')
install=$pkgname.install
changelog=$pkgname.ChangeLog
source=("http://deponie.yamagi.org/quake2/${pkgname#*-}-$pkgver.tar.xz"
"$pkgname.sh"
"$pkgname.desktop")
-sha256sums=('43c445953d60735b722486d5f220059ec2d6da83d008b8134e69e57d9ac087cf'
+sha256sums=('5615c87db9d3a45c076db5dd04861090c146ba1b4f40238d79b8755df993a401'
'7c60d4bd78a528f5cf08425cfdcb87dacf574d3912c44439e623e35f37fbc972'
'e65add2561c7dc4a14061e17a24436f768b69968fbc6fa06022acf9e17d80854')
+prepare() {
+ rm -rf build
+ mkdir -p build
+}
+
build() {
- make -C ${pkgname#*-}-$pkgver
+ cd build
+ cmake ../${pkgname#*-}-$pkgver -DCMAKE_BUILD_TYPE=Release
+ make
}
package() {
+ # game library
+ install -Dm644 build/Release/game.so "$pkgdir"/usr/share/yamagi-quake2/xatrix/game.so
+
cd ${pkgname#*-}-$pkgver
# game launcher
install -Dm755 ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
- # game library
- install -Dm644 release/game.so "$pkgdir"/usr/share/yamagi-quake2/xatrix/game.so
-
# doc
install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README