summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b53408598033
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Shengyu Zhang <la@archlinuxcn.org>
+
+pkgname=yanshi-git
+_pkgname=yanshi
+pkgver=0.57.9d86e63
+pkgrel=1
+pkgdesc='A regular language recognizer generater like Ragel, enhanced with features to approximate context-free grammars and substring grammars'
+arch=('x86_64')
+license=('Custom')
+url="https://github.com/chaitin/yanshi"
+makedepends=('git' 'make' 'gcc')
+depends=('glibc' 'icu')
+provides=('yanshi')
+source=("git+https://github.com/chaitin/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ echo "0.$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+check() {
+ cd ${_pkgname}
+ # make unittest
+}
+
+build() {
+ cd ${_pkgname}
+ make build=release
+}
+
+package() {
+ cd ${_pkgname}
+ install -Dm755 release/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+}