summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4469cc0de9c..01ccef83fbaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
# Contributor: Sebastian Wolf <fatmike303 at googlemail dot com>
pkgname=yape
-pkgver=0.36.2
+pkgver=0.58.2
pkgrel=1
-pkgdesc='Yet another Commodore plus/4 emulator (SDL port)'
+_projectname=yapesdl
+_git_hash=f34a47a03051263df0f27a2b19350f2b0848d85c
+pkgdesc='A decent multiplatform Commodore plus/4 and 64 emulator written in C++ using the SDL 2.0 media API'
arch=('i686' 'x86_64')
-url='http://yape.plus4.net'
+url='http://yapesdl.codeplex.com'
license='GPL'
-depends=('sdl')
-source=(http://yape.homeserver.hu/download/yapeSDL-$pkgver.tar.gz)
-md5sums=('7a44d45106261d464c78ed8319fe3bd9')
+depends=('sdl2')
+source=(${_projectname}::git+https://git01.codeplex.com/${_projectname})
+md5sums=(SKIP)
build() {
+ cd ${srcdir}/${_projectname}
+ git reset --hard ${_git_hash}
make
}
package() {
- install -Dm755 $srcdir/$pkgname $pkgdir/usr/bin/$pkgname
+ install -Dm755 ${srcdir}/${_projectname}/${_projectname} ${pkgdir}/usr/bin/${pkgname}
}