summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 15 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de114da87ace..f0380b19af3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,12 @@ pkgname=(yaru-sound-theme-git
yaru-gtk-theme-git
yaru-gtksourceview-theme-git
yaru-gnome-shell-theme-git
+ yaru-xfwm4-theme-git
yaru-unity-theme-git
yaru-metacity-theme-git
yaru-icon-theme-git
yaru-session-git)
-pkgver=21.10.1.r9.g0d9c70b4c
+pkgver=21.10.1.r50.g670a52f26
pkgrel=1
epoch=1
pkgdesc="Yaru default ubuntu theme"
@@ -30,7 +31,7 @@ pkgver() {
build() {
arch-meson yaru build
- meson configure build -Dubuntu-unity=true
+ meson configure build -Dubuntu-unity=true -Dxfwm4=true
ninja -C build
}
@@ -48,6 +49,9 @@ _delete_all_from_pkgdir_except() {
rm "${pkgdir}"/usr/share/themes/Yaru{,-light}/gnome-shell
rm -r "${pkgdir}"/usr/share/gnome-shell/theme/Yaru{,-light}
fi
+ if [[ "$1" != "xfwm4-theme" ]]; then
+ rm -r "${pkgdir}"/usr/share/themes/Yaru{,-dark}/xfwm4
+ fi
if [[ "$1" != "unity-theme" ]]; then
rm -r "${pkgdir}"/usr/share/themes/Yaru{,-dark}/unity
fi
@@ -102,6 +106,15 @@ package_yaru-gnome-shell-theme-git() {
_delete_all_from_pkgdir_except "gnome-shell-theme"
}
+package_yaru-xfwm4-theme-git() {
+ pkgdesc="Yaru default ubuntu xfwm4 theme"
+ provides=(yaru-xfwm4-theme)
+ conflicts=(yaru-xfwm4-theme)
+
+ DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
+ _delete_all_from_pkgdir_except "xfwm4-theme"
+}
+
package_yaru-unity-theme-git() {
pkgdesc="Yaru default ubuntu unity theme"
provides=(yaru-unity-theme)