summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e945299b63c..42383d7652bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=yasm-git
-pkgver=1.3.0.r36.ge256985c
+pkgver=1.3.0.r48.g009450c7
pkgrel=1
pkgdesc="A complete rewrite of the NASM assembler under the BSD License"
arch=('i686' 'x86_64')
url="https://yasm.tortall.net/"
license=('BSD')
depends=('glibc')
-makedepends=('git')
+makedepends=('git' 'cmake')
provides=('yasm')
conflicts=('yasm')
+options=('staticlibs')
source=("git+https://github.com/yasm/yasm.git")
sha256sums=('SKIP')
@@ -24,22 +25,25 @@ pkgver() {
build() {
cd "yasm"
- ./autogen.sh
- ./configure --prefix="/usr"
- make
+ cmake \
+ -B "_build" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DBUILD_SHARED_LIBS=OFF \
+ ./
+ make -C "_build"
}
check() {
cd "yasm"
- #make check
+ #make -C "_build" test
}
package() {
cd "yasm"
- make DESTDIR="$pkgdir" install
-
- install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/yasm/COPYING"
- install -Dm644 "BSD.txt" "$pkgdir/usr/share/licenses/yasm/BSD.txt"
+ make -C "_build" DESTDIR="$pkgdir" install
+ install -Dm644 {BSD.txt,COPYING} -t "$pkgdir/usr/share/licenses/yasm"
}