summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e17562f1ca1..95401eb5f3c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,13 @@ build() {
cargo build --no-default-features --features "hyper notify-rust" --release
}
+check() {
+ cd $_gitname
+ cargo test --release
+}
+
package() {
cd $_gitname
- install -D -m755 "${srcdir}/${_gitname}/target/release/ydcv-rs" "${pkgdir}/usr/bin/ydcv"
+ cargo install --root "$pkgdir/usr"
+ rm "$pkgdir/usr/.crates.toml"
}