summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87371f12e9bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=ydcv-rs-git
+_gitname="ydcv-rs"
+pkgdesc="A Rust version of ydcv."
+pkgver=0.3.1.48
+pkgrel=1
+arch=('i686' 'x86_64')
+conflicts=("ydcv")
+provides=("ydcv")
+url="https://github.com/farseerfc/ydcv-rs"
+license=('MIT' 'GPLv2')
+depends=('curl')
+makedepends=('git' 'cargo' 'python-pytoml')
+source=('git://github.com/farseerfc/ydcv-rs.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ echo "$(python -c "print(__import__('pytoml').loads(open('Cargo.toml').read())['package']['version'])").$(git rev-list --count HEAD)"
+}
+
+build() {
+ cd $_gitname
+ # cargo build --no-default-features --features "hyper notify-rust" --release
+ cargo build --release
+}
+
+package() {
+ cd $_gitname
+ install -D -m755 "${srcdir}/${_gitname}/target/release/ydcv-rs" "${pkgdir}/usr/bin/ydcv"
+}