summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52d00e69bfb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Your Name <1289747698@qq.com>
+
+pkgname=ydict
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="dictionary/translation tool developed in Rust+Qt"
+arch=('x86_64')
+url="https://github.com/DreamSaddle/youdao-dict"
+license=('GPL3')
+depends=()
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("https://github.com/DreamSaddle/youdao-dict/releases/download/$pkgver/YDict-$pkgver.tar.gz")
+noextract=()
+md5sums=('SKIP')
+
+prepare() {
+ echo ""
+}
+
+build() {
+ echo "此软件通过打包好的二进制文件安装, 无需编译."
+}
+
+package() {
+ cd "YDict-$pkgver/scripts"
+ chmod +x install.sh
+ ./install.sh
+}