summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5749585828bd..893d2ec33f2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
_pkgname=ydotool
pkgname=$_pkgname-git
-pkgver=v0.1.8.r45.g3ebfd62
+pkgver=v0.2.0.r7.gce27b46
pkgrel=1
pkgdesc="Generic command-line automation tool (no X!), works on Wayland"
-arch=('i686' 'x86_64')
-depends=('libevdevplus' 'libuinputplus' 'boost-libs')
+arch=('i686' 'x86_64' 'armv7h' 'aarch64' 'pentium4')
+depends=('boost-libs')
makedepends=('cmake' 'git' 'make' 'pkg-config' 'boost')
url="https://github.com/ReimuNotMoe/ydotool"
license=('MIT')
@@ -31,15 +31,18 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DSTATIC_BUILD=0
make
+
+ cd manpage
+ gzip ydotool.1 ydotoold.8
}
package() {
cd "$srcdir/${_pkgname}"
- make DESTDIR="$pkgdir" install -C build/
install -Dm644 Daemon/ydotool.service "$pkgdir/usr/lib/systemd/user/ydotool.service"
- # Workaround upstream bug
- if [ -f "$pkgdir/usr/bin/libydotool.so" ]; then
- mv "$pkgdir/usr/"{bin,lib}"/libydotool.so"
- fi
+ cd build
+ install -Dm755 ydotool "$pkgdir/usr/bin/ydotool"
+ install -Dm755 ydotoold "$pkgdir/usr/bin/ydotoold"
+ install -Dm644 manpage/ydotool.1.gz "$pkgdir/usr/share/man/man1/ydotool.1.gz"
+ install -Dm644 manpage/ydotoold.8.gz "$pkgdir/usr/share/man/man8/ydotoold.8.gz"
}