summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2076fb5f73d..477b0dcf242a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgname='yeecli'
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='Command-line utility for controlling the YeeLight RGB LED lightbulb'
arch=('any')
url='https://gitlab.com/stavros/yeecli'
+_url_pypi='https://pypi.org/project/yeecli'
license=('BSD')
-depends=('python' 'python-click' 'python-ifaddr' 'python-yeelight')
+depends=('python-click' 'python-ifaddr' 'python-yeelight')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('2a534273ac7997f7e3991d22153e8d17efc87d2e9ee99e6bb4acb8097206d585')
@@ -21,8 +22,8 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.rst'
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
+ install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: