summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6ae0ec0a32c..d4070f8ba023 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: theflameemperor <un.own.cry@gmail.com>
pkgname=ygopro-koishipro
-pkgver=2019.3.6
-pkgrel=5
+pkgver=2019.3.15
+pkgrel=1
_pkgrel=1
zipFile=KoishiPro-linux-full-${pkgver}.zip
pkgdesc="Link compatable ygopro client with AI"
@@ -12,7 +12,7 @@ depends=('mono' 'libevent')
makedepends=('patchelf')
source=("https://github.com/purerosefallen/ygopro/releases/download/$pkgver/$zipFile")
noextract=($zipFile)
-sha256sums=('936ec2c86f4d30e621af807f67e6f2182280c06e92cc98f1162f2e91a96ffdd5')
+sha256sums=('2ae0eccd26f24e3333e31e2baf1f901f07b0c309da6f096bc07a27f7b70f508b')
options=('!strip' 'emptydirs')
prepare(){
@@ -21,7 +21,6 @@ prepare(){
mkdir -p ../usr/share/applications
cp ../koishipro.desktop ../usr/share/applications
unzip -qq -o $zipFile -d $pkgname
- rm -rf ./$pkgname/deck/
patchelf --remove-needed libevent_pthreads-2.0.so.5 ./$pkgname/ygopro
patchelf --add-needed libevent_pthreads.so ./$pkgname/ygopro
patchelf --remove-needed libevent-2.0.so.5 ./$pkgname/ygopro
@@ -31,9 +30,11 @@ prepare(){
package(){
outputDir="$pkgdir/opt/$pkgname"
mkdir -p $outputDir
+ echo $outputDir
cp -r ../usr $pkgdir
cp ../YGOPro.png $outputDir/
cp -dR $pkgname/* $outputDir
find $outputDir -type d -exec chmod 777 {} \;
find $outputDir -type f -exec chmod 777 {} \;
+ rm $outputDir/deck/*
}