summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 14 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab34c17f79ef..7bbb4e36f623 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,30 @@
pkgname=ykchorus
_plugin_uri="https://chrisarndt.de/plugins/$pkgname"
-pkgver=0.2.3
-pkgrel=2
-pkgdesc='A stereo dual-chorus audio effect LV2, LADSPA and VST2 plugin and JACK application'
+pkgver=0.2.4
+pkgrel=3
+pkgdesc='A stereo dual-chorus audio effect CLAP/LADSPA/LV2/VST2/VST3 plugin and JACK application'
arch=(x86_64 aarch64)
url="https://github.com/SpotlightKid/$pkgname"
-license=(GPL2)
-depends=(gcc-libs libglvnd)
+license=(GPL-2.0-only)
+depends=(gcc-libs glibc libglvnd libx11 libxcursor libxext libxrandr)
+makedepends=(dbus)
checkdepends=(kxstudio-lv2-extensions lv2lint)
optdepends=(
'jack: for stand-alone JACK client program'
+ 'clap-host: for CLAP plugin'
'ladspa-host: for LADSPA plugin'
'lv2-host: for LV2 plugin'
- 'vst-host: for VST plugin'
+ 'vst-host: for VST2 plugin'
+ 'vst3-host: for VST3 plugin'
)
-groups=(ladspa-plugins lv2-plugins pro-audio vst-plugins)
+groups=(clap-plugins ladspa-plugins lv2-plugins pro-audio vst-plugins vst3-plugins)
source=("https://github.com/SpotlightKid/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('f1783e5fe73efb695fe9eeb298c0494030deb4ed29a048374f6b6ea412826716')
-
-prepare() {
- cd $pkgname-$pkgver
- # We don't want the DSSI version:
- sed -i -e '/ykchorus-dssi/d' Makefile
- sed -i -e '/dssi_dsp$/d' plugins/YKChorus/Makefile
-}
+sha256sums=('1dfd5981c52e5567eea15b43961f6bd3a88a96c0e8eabd9f56d823d24edb3970')
build() {
cd $pkgname-$pkgver
- make
+ make SKIP_NATIVE_AUDIO_FALLBACK=true
}
check() {
@@ -39,6 +35,7 @@ check() {
}
package() {
+ depends+=(libdbus-1.so)
cd $pkgname-$pkgver
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
}