summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0a9552f825a..4e0a57713f3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Harsh Barsaiyan <hbarsaiyan at gmail dot com>
pkgname=youtube-music-bin
pkgver=1.19.0
-pkgrel=1
+pkgrel=2
pkgdesc="YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)"
arch=('x86_64')
url="https://th-ch.github.io/youtube-music"
@@ -12,16 +12,18 @@ optdepends=('libnotify: desktop notifications'
'libappindicator-gtk3: tray icon')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
+install="${pkgname%-bin}.install"
source=("https://github.com/th-ch/youtube-music/releases/download/v$pkgver/${pkgname%-bin}_${pkgver}_amd64.deb"
- "https://github.com/th-ch/youtube-music/raw/v$pkgver/license")
+ "https://github.com/th-ch/youtube-music/raw/v$pkgver/license"
+ "${pkgname%-bin}.sh")
sha256sums=('f8bebf16cd24463dd830bdf3dbd59cc6a4f44a5422a2b995f1ef8bb260325beb'
- 'e7e14b3b771ecadb23f6ee0b6f99d1553e385e35cdb44fc8e36ee7c878dacd08')
+ 'e7e14b3b771ecadb23f6ee0b6f99d1553e385e35cdb44fc8e36ee7c878dacd08'
+ '00a19851f1b91c7fbefede55f6a17a51182d8bb41187569684f9f58566a83b26')
package(){
bsdtar xfv data.tar.xz -C "$pkgdir"
- install -d "$pkgdir/usr/bin"
- ln -s "/opt/YouTube Music/${pkgname%-bin}" "$pkgdir/usr/bin/${pkgname%-bin}"
+ install -Dm755 "${pkgname%-bin}.sh" "$pkgdir/usr/bin/${pkgname%-bin}"
install -Dm644 license -t "$pkgdir/usr/share/licenses/${pkgname%-bin}"
}