summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 21 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b69d68b1fde..9859153a67ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,8 @@
pkgname=yubico-authenticator
_app_id=com.yubico.yubioath
pkgdesc="Yubico Authenticator for Desktop"
-pkgver=6.4.0
-pkgrel=6
-_flutter_ver=3.19.5
+pkgver=7.0.0
+pkgrel=4
arch=('x86_64' 'aarch64')
url="https://github.com/Yubico/yubioath-flutter"
license=('Apache-2.0')
@@ -23,6 +22,7 @@ makedepends=(
'chrpath'
'clang'
'cmake'
+ 'fvm'
'git'
'ninja'
'python-build'
@@ -30,16 +30,22 @@ makedepends=(
'python-poetry-core'
'python-wheel'
)
-_commit=c44d65eb6efc9e82b74eb44f228c3937bdc1e071 # tags/6.4.0^0
-source=("git+https://github.com/Yubico/yubioath-flutter.git#commit=${_commit}?signed"
- "flutter-${_flutter_ver}.tar.xz::https://storage.googleapis.com/flutter_infra_release/releases/stable/linux/flutter_linux_${_flutter_ver/.hotfix/+hotfix}-stable.tar.xz")
-validpgpkeys=('AF511D2CBC0F973E5D308054325C8E4AE2E6437D' # Adam Velebil <adam.velebil@yubico.com>
- '20EE325B86A81BCBD3E56798F04367096FBA95E8') # Dain Nilsson <dain@yubico.com>
-sha256sums=('5409741c3e10645fe9b41e497e34f94bc95c7c8d79a71c645c00486c0484f40c'
- '6590607e7f2fb23bcc7e0a2d6aac292f9208cbf12a40862c281058c758604fb3')
+source=("git+https://github.com/Yubico/yubioath-flutter.git#tag=$pkgver?signed")
+sha256sums=('e728ae5c5e94f7ed9b92a76e1e5dc91a6e4775da265b51379f027bf47f6bf84d')
+validpgpkeys=('20EE325B86A81BCBD3E56798F04367096FBA95E8') # Dain Nilsson <dain@yubico.com>
prepare() {
cd yubioath-flutter
+ export FVM_CACHE_PATH="$srcdir/fvm"
+ fvm install 3.19.6
+ fvm global 3.19.6
+
+ # Disable analytics
+ fvm flutter --disable-analytics
+
+ # Pull dependencies within prepare, allowing for offline builds later on
+ fvm flutter pub get
+
desktop-file-edit --set-key=Exec --set-value="authenticator" --set-icon="${_app_id}" \
resources/linux/linux_support/com.yubico.authenticator.desktop
@@ -54,18 +60,14 @@ build() {
GIT_DIR='.' python -m build --wheel --no-isolation
popd
- export FLUTTER_HOME="$srcdir/flutter"
- export PATH="${FLUTTER_HOME}/bin:${PATH}"
- flutter --disable-analytics
- flutter pub get
- flutter build linux
+ export FVM_CACHE_PATH="$srcdir/fvm"
+ fvm flutter build linux
}
check() {
cd yubioath-flutter
- export FLUTTER_HOME="$srcdir/flutter"
- export PATH="${FLUTTER_HOME}/bin:${PATH}"
- flutter test
+ export FVM_CACHE_PATH="$srcdir/fvm"
+ fvm flutter test
}
package() {
@@ -102,3 +104,4 @@ package() {
# Remove insecure RUNPATH pointing to build dir
chrpath --delete "$pkgdir/opt/$pkgname"/lib/*.so
}
+