summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ef4a010b479..b0544b83f7db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,18 @@
_pkgname=yuzu
pkgname=$_pkgname-canary-git
-pkgver=r8139.8c9a8123d
+pkgver=r8185.c91add0ad
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
url="https://github.com/yuzu-emu/yuzu-canary"
license=('GPL2')
-depends=('shared-mime-info' 'desktop-file-utils' 'sdl2' 'qt5-base' 'qt5-multimedia' 'mbedtls')
-makedepends=('git' 'cmake')
+depends=('shared-mime-info' 'desktop-file-utils' 'sdl2' 'qt5-base' 'qt5-multimedia')
+makedepends=('git' 'cmake' 'python')
optdepends=('libxkbcommon-x11: for X11 support'
'qt5-wayland: for Wayland support')
+provides=('yuzu-cmd')
+conflicts=('yuzu-cmd')
source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-canary"
'git+https://github.com/svn2github/inih'
'git+https://github.com/yuzu-emu/ext-boost'
@@ -22,6 +24,7 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-canary"
'git+https://github.com/fmtlib/fmt'
'git+https://github.com/lz4/lz4'
'git+https://github.com/yuzu-emu/unicorn'
+ 'git+https://github.com/DarkLordZach/mbedtls'
'git+https://github.com/ogniK5377/opus')
md5sums=('SKIP'
'SKIP'
@@ -33,6 +36,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -54,6 +58,7 @@ prepare() {
git config submodule.fmt.url "$srcdir/fmt"
git config submodule.lz4.url "$srcdir/lz4"
git config submodule.unicorn.url "$srcdir/unicorn"
+ git config submodule.mbedtls.url "$srcdir/mbedtls"
git config submodule.opus.url "$srcdir/opus"
git submodule update --init --recursive
}