summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d612fdf2fa4a..789665954fd6 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=r13523.d47960cf3
+pkgver=r13623.e0cf27650
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
@@ -40,6 +40,12 @@ build() {
# Hopefully temporary fix for a compilation error involving fmt
CXXFLAGS+=" -DFMT_USE_USER_DEFINED_LITERALS=0"
+ # Flag to disable pre-compiled headers so boost can build properly
+ CXXFLAGS+=" -DENABLE_PRECOMPILED_HEADERS=OFF"
+
+ # Flag to fix SDL exceptions occurring in some users' builds
+ CXXFLAGS+=" -I/usr/include/SDL2 -D_REENTRANT -pthread -lSDL2"
+
mkdir -p build && cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \