summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cd54a7a7da42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Prayz Jomba <prayzjomba@protonmail.com>
+pkgname=ywatch-git
+pkgver=0.6.3
+pkgrel=1
+pkgdesc="Watch youtube videos with mpv while saving the video to disk."
+arch=(any)
+url="https://github.com/prayzjomba/ywatch.git"
+license=('GPL')
+depends=('youtube-dl' 'xclip' 'mpv' 'python-rich' 'python-pyperclip' 'python-func-timeout')
+makedepends=('git' 'make' 'python-setuptools')
+provides=(yw)
+install=
+changelog=
+source=("$pkgname"::"git+$url#branch=$pkgver")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$pkgname"
+ printf "0.6.3.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "$pkgname"
+ python setup.py build
+}
+
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
+}