summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c3d4ba89440..60a8db1e64f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
pkgname=zbar-git
-pkgver=0.23.92.r22.g4e0f618
+pkgver=0.23.93.r2.ga549566
pkgrel=1
pkgdesc="Application and library for reading bar codes from various sources"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/mchehab/zbar"
-license=('LGPL')
-depends=('dbus' 'imagemagick' 'libsm' 'libxv' 'v4l-utils')
-makedepends=('gtk3' 'qt5-x11extras' 'python' 'xmlto' 'docbook-xsl' 'gobject-introspection')
+license=(LGPL-2.1-or-later)
+depends=('glibc' 'gcc-libs' 'dbus' 'imagemagick' 'libxv' 'v4l-utils')
+makedepends=('git' 'gtk3' 'qt5-x11extras' 'python' 'xmlto' 'docbook-xsl' 'gobject-introspection')
optdepends=('gtk3: for zbar-gtk'
'qt5-x11extras: for zbar-qt'
'python: for zbar python bindings')
+conflicts=('zbar' 'zbar-gtk' 'zbar-qt' 'python-zbar')
provides=('zbar' 'zbar-gtk' 'zbar-qt' 'python-zbar')
source=("$pkgname"::'git+https://github.com/mchehab/zbar.git')
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
@@ -24,9 +25,6 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
autoreconf -vfi
-
- # Removed in Python 3.9. Ignored in Python 3.0+ anyway.
- sed -i '/tp_print/d' python/enum.c
}
build() {