summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b91f4481214..6bdab505317f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ if [[ "$CARCH" == x86_64 ]]; then
fi
pkgname=zdoom-git
-pkgver=20130829
+pkgver=2.8pre.r457.g85fb8c4
pkgrel=1
pkgdesc="An enhanced Doom port with additional support for Heretic, Hexen and Strife (git version)."
arch=('i686' 'x86_64')
@@ -48,7 +48,8 @@ _libdir=/usr/lib/zdoom
_sharedir=/usr/share/games/zdoom
pkgver() {
- date +%Y%m%d
+ cd zdoom
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {